Jump to content
Sal's RuneScape Forum
  • entries
    192
  • comments
    841
  • views
    60,657

That Time I Played Runescape

Jethraw

964 views

Logged into Runescape today for the first time in 104 days. The first time I'd logged into RS since the release of the last Grandmaster Quest, having spent a while on RS07 after that.

 

I eventually got logged in (the website it self froze my laptop at first). I disconnected during the opening cinematic, then disconnected twice more before I actually got moving. I ran from Lumbridge to Falador, disconnecting four more times again.

 

I gave it thirty minutes then tried again, this time the game ran more smoothly, but there was a stuck audio that I couldn't turn off despite my audio settings. Then I disconnected.

 

 

Safe to say I won't be returning to RS3, which is probably for the best anyway. Still contemplating membership and having another stab at RS07, but I think RS3 I'll just have to watch from afar.



6 Comments


Recommended Comments

I tried it too a few weeks ago together with tabt and my experience was quite similar...

 

it took me over an half hour to actually get into the game

 

I was however quite content to see that I still had all my old pre cmb update items equipped and that my santa hat pet troll was showing in f2p :)

Share this comment


Link to comment

Is RS3 free?

Anyways, every time I log into EOC, it starts by the website itself lagging then the "loading 0-100%" keeps happening. I'm not sure why.

I think I logged in around a year ago. :/

And this is a Runescape forum.

Share this comment


Link to comment

Is RS3 free?

Anyways, every time I log into EOC, it starts by the website itself lagging then the "loading 0-100%" keeps happening. I'm not sure why.

I think I logged in around a year ago. :/

And this is a Runescape forum.

Yes. RS3 is now the normal Runescape. What you're calling EoC is RS3.

Share this comment


Link to comment

Aabid, on , said:

 

Is RS3 free?

Anyways, every time I log into EOC, it starts by the website itself lagging then the "loading 0-100%" keeps happening. I'm not sure why.

I think I logged in around a year ago. :/

And this is a Runescape forum.

Yes. RS3 is now the normal Runescape. What you're calling EoC is RS3.

 

So what that new "beta" they introduced? That is something different?

Share this comment


Link to comment

reepicheep, on , said:

 

Aabid, on , said:

 

Is RS3 free?

Anyways, every time I log into EOC, it starts by the website itself lagging then the "loading 0-100%" keeps happening. I'm not sure why.

I think I logged in around a year ago. :/

And this is a Runescape forum.

Yes. RS3 is now the normal Runescape. What you're calling EoC is RS3.

 

So what that new "beta" they introduced? That is something different?

 

The beta you're talking about is probably the HTML5 beta, which is what RS3 will turn into soon. So yes, that's different but only slightly. Don't worry about the beta, RS3 is the game you want.

Share this comment


Link to comment

I think for the sake of balance that I should point out that RS3 is NOT the game I want! :-)

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×

Important Information

By using this site, you agree to our Guidelines and Privacy Policy.