Jump to content
Sal's RuneScape Forum
Sign in to follow this  
thepatanator

Returning Post Issues

Recommended Posts

I've been inactive from Sal's Realm for a while. I came back and started playing again and tried to make a little intro post in the Lounge and it said I didn't have permission. I figured it was a verification issue so I verified my email etc and it's still a problem. Can anyone help me? 

 

Thanks in advance

Share this post


Link to post
Share on other sites

We updated our forum a few months ago and it's probably some issue with that. An administrator will have to investigate. I can't see anything in your account that would prevent you from posting in the Scape Lounge. Sort of weird because it's not like you're some special member group - you're just a normal member.

Welcome back.

Edited by Sobend

Share this post


Link to post
Share on other sites

I'm a returning member too and I've been on and off on this forum for a decade now. >_< I DID get an authorisation notification where I was asked to scan a QR code to 'verify' my account but I skipped that and haven't faced any issues so far. :biggrin:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Guidelines and Privacy Policy.